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4.0 Preface 

This manual describes the installation and operation of DPFlex Gen 2 sensorless brushless motor 

drives manufactured by Allied Motion Technologies, Inc. 

Every effort has been made to ensure accuracy of information in this manual. However, Allied 

Motion assumes no responsibility for any errors or omissions. The information contained within 

this document is regularly reviewed and we welcome your critical evaluation and suggestions for 

improvement. Allied Motion reserves the right to modify all documentation without prior notice. 

Be sure to download the most recent revision of this manual from the company website. 

This manual is supplied to the user with the understanding that it will not be reproduced, 

duplicated, or disclosed in whole or in part without the express written permission of Allied 

Motion Technologies, Inc. 

Table 1: Applicable Allied Motion Products 

PRODUCT FAMILY PART NUMBER DESCRIPTION 

DPFlex Gen 2 DPX-2043xxxx DPFlex Gen 2 Sensorless Brushless Motor Drives 

5.0 Inspection Upon Receipt 

All Allied Motion products are thoroughly inspected and tested before leaving the factory. 

Although our products are packaged with extreme care, it is important that the user complete a 

thorough inspection of the product upon arrival. 

Examine the condition of the shipping container and materials. If damage is found, notify the 

commercial carrier involved. It is the user’s responsibility to file any necessary damage claims 

with the carrier. Our products are shipped EXW (ex works), unless other arrangements have been 

made. Allied Motion is not responsible for carrier mishandling. 
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6.0 Safety 

 

CAUTION: GENERAL WARNING 

Read all provided documentation before assembly and commissioning. Failure or improper use of 
this equipment can cause property damage, personal injury, and death. The final responsibility for 
the safe use of Allied Motion products is solely that of the user. 

 

 

CAUTION: HIGH VOLTAGE 

When drives are powered, high voltages are present on the connector and elsewhere in the drive 
and can be dangerous. The drive cover should not be removed with the power on, and then only by 
a competent and trained engineer. It is important that all system components be properly 
grounded. 

 

 

CAUTION: HOT SURFACE 

When drives are powered, the heat sink and internal components can become very hot. The drive 
cover should not be removed until cool, and then only by a competent and trained engineer. 

7.0 Overview 

The DPFlex system includes the following components: the product datasheet, this user manual, 

the DPFlex drive, DP.D commissioning software, and cabling for connecting a DPFlex drive to 

power, motor, and personal computer (PC). 

The DPFlex drive provides sensorless torque and/or velocity control of rotary brushless DC 

(BLDC) motors at performance levels exceeding those of conventional Hall sensor commutated 

drives. DPFlex detects motor rotor position at stall through an innovative algorithm based on 

motor phase-inductance measurement, thus no commutation sensors are required. The DPFlex 

may be integrated into a motor (e.g. into the bell end) or mounted separately. 

Allied Motion’s DP.D software for Microsoft® Windows® 2000/XP/Vista/7/8 is used to tune, 

configure, and program the DPFlex drive. It provides I/O setup and configuration tools, along 

with motor verification and performance analysis tools. 

DPFlex is suitable for a wide range of applications including control of fans, pumps, 

compressors, centrifuges, drills, mills, conveyors, office and medical equipment, automotive 

subsystems, and many others. See datasheet for further explanation of product features, benefits, 

and specifications. 
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8.0 Sensorless Drive Technology 

8.1 Understanding Commutation 

Torque in an electric motor is the result of the interaction between two magnetic fields, 

one from the rotor and the other from the stator. These two magnetic fields must move in 

sequence with each other to produce torque. Sequentially controlling current through the 

motor so as to produce torque is what is known as commutation. To accomplish this, the 

DPFlex uses a sensorless six-step (trapezoidal) commutation method which relies on the 

motor’s back electromotive force (back-EMF) for position sensing. 

8.2 Six-Step (Trapezoidal) Commutation 

In this method, there are only two of three phases of stator coils energized by the DC 

source at any one given time. To complete one electrical cycle or magnetic field rotation, 

every phase is energized four times (two times in the positive polarity and the other two 

in the negative polarity). BLDC motors are commutated by six 60 degree steps during 

each full 360 degree electrical cycle. Because the transition from one step to the next is 

discrete, the waveform of the field is shaped like a trapezoid.  

 
Figure 1: Six-Step Commutation Phase Current and Back-EMF 

Six-step commutation is simple and can be used for many types of BLDC motors. The 

simplicity and effectiveness of the method makes it an attractive choice for commutation 

even at high speed. 

http://www.alliedmotion.com/
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8.3 Sensorless Six-Step Commutation 

Once the shaft of the motor is spinning sufficiently fast, the induced back-EMF voltage 

caused by the time varying magnetic flux linking the stator windings can be measured by 

the drive. This magnetic flux is produced from the permanent magnets of the rotor. It is 

possible to use this information to commutate the motor without any other position 

feedback information. This is what is meant by the term sensorless: it is the absence of 

any physical position feedback devices in the motor. 

During six-step commutation, the coils that are energized are the two that yield the 

maximum developed electromagnetic torque. For a WYE connected motor, the third coil 

is off and so the back-EMF voltage can be measured at its phase terminal. Each of the 

three coils is energized (ON) for 120 electrical degrees and is then de-energized (OFF) 

for 60 electrical degrees. This pattern is repeated again and again every 180 electrical 

degrees and the current is switched in direction at each 180 degree segment. 

 
Figure 2: Six-Step Commutation Sequence 

The back-EMF voltage induced while in the OFF phase undergoes a polarity reversal 

during the time the phase is OFF. The bias voltage is the voltage of the neutral point of 

the WYE connection. Ideally, the drive should shut OFF a coil as the induced back-EMF 

across that coil is undergoing a polarity reversal. The coil should then be re-energized 

once the voltage has changed polarity and that coil can contribute to torque production. In 

order to do this, the controller samples the voltage of the OFF phase once the current in 

that phase has dropped to zero. Once it detects that the rotor flux is generating a back-

EMF of the proper polarity, it shuts OFF the coil that is just beginning to go through this 

voltage reversal process and energizes the one that just finished this process.  
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The drive uses the physical properties of the motor to assess when the time for switching 

is appropriate. The motor back-EMF constant (Ke) of the motor is used to calculate how 

much flux there is per pole. By integrating the induced back-EMF voltage in the OFF 

phase and waiting for the proper amount of flux to accumulate, the drive can commutate 

at the appropriate time. Since Ke is constant, it is speed independent and therefore 

applicable at all speeds at which the back-EMF of the motor can be detected by the drive. 

8.4 Special Considerations for Sensorless Commutation  

During the process of commutation, current in one phase must drop to zero and be 

transferred to the phase that is just coming ON. Because of the fact that the coils are not 

mutually coupled 100%, and that each coil has its own leakage reactance, there will be a 

portion of time, albeit brief, where all three coils have current in them. During this period 

of time, an accurate back-EMF cannot be obtained from the voltage sense circuit on the 

controller. 

Immediately after commutation, the drive will shut OFF the phase voltage and wait until 

it determines that an accurate back-EMF signal can be obtained from the analog input 

dedicated to back-EMF sensing in the OFF phase.  

It is only after this has been successfully detected that the drive will begin to use the 

measured back-EMF for commutation purposes. Since DPFlex monitors the back-EMF 

feedback and activates the back-EMF sensing itself, there is no parameter associated with 

the coil-coil current transfer.  

8.5 Sensorless Startup  

As the induced back-EMF is proportional to speed, a sensorless controller needs a means 

of finding the rotor position at stall in order to start the motor and accelerate it to a 

sufficiently high speed to be able to detect the back-EMF voltage. Startup is undoubtedly 

the biggest hurdle for any sensorless control algorithm.  

Conventional methods drive a current through the motor windings in order to force the 

rotor into a known position to ensure proper motor start. This can cause up to 180 degrees 

of motor rotation in the direction opposite to that which is actually desired. Also, the 

current required to orient the rotor depends on the inertial and frictional load of the 

motor. If the initial current to orient the motor is too high, there may be overshoot and 

ringing in the system. If the current is too low, the motor may not start at all. Such a 

system is not robust with respect to system load conditions.  

More advanced methods determine rotor position based on the motor-phase saturation 

inductance change. The drive generates six short and opposing current pulses that drive 

the motor phases into saturation. The drive calculates the motor rotor position based on 

the saturation inductance change in each phase. Allied Motion refers to this procedure as 

the Ping Method. The rotor remains stationary during the initial ping period because the 

current pulses are short and in opposing sequence. In most cases, the motor reaches 
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sufficient speed before the next commutation sector change for the back-EMF 

commutation algorithm to take over. In a few cases, usually if the load on the motor is 

extremely heavy, the ping process repeats while the motor rotates at low speeds below 

the back-EMF commutation threshold. This is possible because the ping period time is 

negligible with respect to the time between sector transitions at low motor speeds. The 

Ping Method guarantees unidirectional motor start, which is independent of motor 

loading conditions. Thus, the system is robust with respect to system load conditions. 

9.0 Wiring 

For information regarding terminal assignments and function, see product datasheet. To ensure 

safe operation of the DPFlex, your application must meet the following requirements: 

 

CAUTION: GENERAL WARNING 

Failure to comply with the requirements listed below may create an electrical hazard. 

9.1 Power Cabling 

Use two 16 AWG, 105 °C, twisted cables (with at least one twist per centimeter) made as 

short as possible to connect the DC power supply to the DPFlex.  

Connect a 30 A fast blow fuse between the positive voltage from the DC power supply 

and J3 on the DPFlex.  

It is recommended that an additional electrolytic capacitor be placed across J3/J4 on the 

DPFlex, as close as possible to the J3/J4 connectors. Rule of thumb sizing for this 

capacitor is 30 μF per ampere of the DPFlex’s rated current. Cables running to and from 

this added capacitor should be twisted together using 1 twist or more per centimeter. 

If extra capacitance is used, it is highly recommended that a pre-charge circuit be used to 

limit the inrush current caused when charging this capacitance. The limiting resistor 

should then be shorted out using a relay or some other appropriate means. 

Spot ground the DPFlex drive itself. 

9.2 Motor Cabling 

Use three 16 AWG, 105 °C, twisted cables (with at least one twist per centimeter) made 

as short as possible to connect the motor to the DPFlex. 

http://www.alliedmotion.com/
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Figure 3: Power and Motor Wiring Diagram 

9.3 Communications Cabling 

The signal cables for J1 must be less than 1 meter in length.  

Use a USB cable to connect the PC to the USB-UART adapter.  

The serial communications connector on the drive uses TTL signals. If communication 

with the drive from a device using standard RS-232 signals is desired, a means to convert 

the signal levels between the two devices must be provided.  

http://www.alliedmotion.com/


 User Manual: DPFlex Gen 2 

Allied Motion Technologies, Inc.  http://www.alliedmotion.com 

June 2, 2015 34-2003 R3 Page 12 of 34 

10.0 Power Dissipation 

The DPFlex generates heat as power is consumed during operation. Note that the DPFlex requires 

an optimal heatsink in order to realize its full output power rating. Therefore heatsink the 

baseplate of the DPFlex using the following power dissipation curve as a guide. Note that the 

power dissipation curve was generated with balanced 3-phase sinusoidal current, at a 100 Hz 

fundamental and a 20 kHz switching frequency. 

 
Figure 4: Power Dissipation Curve, DPFlex, 24 V, 30 A Model 

 

 
Figure 5: Safe Operating Area, DPFlex, 24 V, 30 A Model 
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11.0 Getting Started 

11.1 Included Software 

The software provided with the DPFlex drive includes DP.D, a Microsoft Windows based 

application that enables a user to configure and monitor the drive, and a USB-to-serial 

driver that enables a PC to communicate with the drive through a standard USB port.  

To install and run the DP.D and USB-to-serial driver software, a PC is needed with the 

following minimum requirements: 

 Windows XP with SP2 or higher 

 A USB port or an RS-232 serial communication port capable of 115200 bps  

 133 MHz or higher Pentium-compatible microprocessor  

 At least 64 MB of RAM  

 50 MB available hard drive storage  

 SVGA or higher resolution monitor.   

11.2 Installing the Software  

The DPFlex software is packaged on a CD-ROM containing the DP.D software and 

USB-to-serial driver, or may be downloaded from the company website. 

To run the installation utility, insert the CD in your CD-ROM drive. Wait for the 

installation utility to auto run. If the installation utility does not automatically run, open 

the “SETUP.EXE” program found in the root of the CD. 

 
Figure 6: Installation Utility, Main Menu 
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To install DP.D, in the installation utility, choose “Install DP.D”. The installation utility 

launches the DP.D installation wizard. Follow the instructions in the wizard to install 

DP.D. Note that DP.D requires an Open Database Connectivity driver to be installed on 

the PC. If you do not have one, you can install one by running the “MDAC_TYP.EXE” 

program in the “MDAC2_8” directory found on the CD.  

   
Figure 7: Installation Utility, Install DP.D 

To install the USB-to-serial driver, in the installation utility, choose “Install USB-to-

serial Driver”. The installation utility launches the driver installation wizard. If you want 

to change where the driver is installed, choose “Browse” to select another location. Then 

choose “Next” to install the driver or “Cancel” to abort the operation. 
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Figure 8: Installation Utility, Install USB-to-Serial Driver 

11.3 Connecting to the DPFlex 

To configure the DPFlex drive using the installed DP.D software, it must be connected to 

power, to a motor, and to the PC.   

Connect the DPFlex to the PC by plugging one end of the USB A to B cable into the 

USB port of the USB-UART adapter cable. Plug the free end of the USB A to B cable 

into a USB port on the PC. Note that if the USB-to-serial driver has not been installed, 

the PC will launch a device driver install wizard when it detects the adapter cable. Use 

the wizard to install the driver from the driver directory on the DP.D CD. Then, plug the 

free end of the adapter cable into the serial communications connector on the DPFlex 

drive then start DP.D. 

When DP.D starts, it opens a blank System Navigation Tree which is used to create and 

manage DPFlex configuration(s).  

 
Figure 9: DP.D System Navigation Tree 
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To add a DPFlex configuration, right-click the “System” branch in the System 

Navigation Tree and choose “Connection”, or double-click the “System” branch. DP.D 

then displays the Interact form, which lists defined connections. Choose “Add”.  

 
Figure 10: Interact Form 

DP.D then displays the Connection Info Form. If the port to which the DPFlex controller 

is connected is not displayed in the “Port” drop-down list, choose “Scan Ports”. DP.D 

will then scan the PC for serial ports or the USB-to-serial adapter. If the USB port does 

not appear in the list, check the following items and re-scan: that the USB-to-serial driver 

is installed, that the USB-to-serial cables are properly connected.  

In the “Port” drop-down list, choose the port to which the DPFlex controller is connected.  

 
Figure 11: Connection Info Form 

Choose “Test” to confirm the connection to the controller is working. If the test fails, 

check the following items and re-test: that the communication cables are properly 

connected, that the DPFlex controller is powered.  

Choose “OK” to accept the connection or “Cancel” to abort the operation. The Interact 

Form now lists the connection to the controller. 
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Figure 12: Interact Form (With Enabled Connection) 

Choose “OK” to accept the controller connection configuration or “Cancel” to abort the 

operation. DP.D updates the System Navigation Tree for the new configuration. 

 
Figure 13: DP.D System Navigation Tree (With Enabled Connection) 

Each DPFlex configuration shows the enabled COM port and provides access to the 

following items: Stimulus Tools, Motor, Current Compensator, Velocity Compensator, 

Inputs, Faults, Registers, and Digital Output. 

11.4 Saving Configurations 

To save a DPFlex configuration, choose “File” -> “Save”. If the configuration has not 

been previously saved, DP.D will display a browser by which to select a path and file 

name for the configuration file.  

To create a new configuration, choose “File” -> “New”. If the current configuration has 

not been saved, DP.D will prompt to either save or discard the configuration. 

To open a configuration, choose “File” -> “Open”. DP.D will display a browser. Select 

the path and file name for the desired configuration and choose “Open”. 
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11.5 Loading New Firmware 

To load new firmware and view system properties, right-click the “Gen2_DPFlex 

(COMx)” leaf in the navigation tree and choose “Interact”, or double-click the leaf. DP.D 

then displays the DPFlex System Properties Form. 

 
Figure 14: DPFlex Properties Form 

The DPFlex Properties Form displays the following controller information: the supply 

voltage, drive temperature, the firmware version including date and time of compilation, 

and the DPFlex's current and voltage ratings. 

To load new firmware, click “Show Details” -> “Load New Firmware”. DP.D will then 

present a browser by which to select the appropriate path and file name. 

12.0 Creating Applications 

This chapter describes how to configure and deploy the DPFlex for a particular application, 

which includes: how to configure the DPFlex for a specific motor, tune the current and velocity 

control loops, check the digital and analog inputs, configure the digital output, monitor and clear 

drive faults, and use the DP.D digital oscilloscope. 

12.1 Stimulus Tools 

The Stimulus Tools allow the user to control either motor current, torque, or velocity 

from the DP.D interface. 

Before using the Stimulus Tools, be sure to first successfully complete the Motor 

Verification process (see Motor Parameters for instructions), and input appropriate 

current and velocity loop gains (see Current Compensator and Velocity Compensator, 

respectively). Note that the Motor Verification process will provide initial current loop 

gains, however in some cases these settings should be fine-tuned using the Current 

Compensator. 
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12.1.1 Current Stimulus 

The Current Stimulus Tool allows the user to command motor current or torque 

from the DP.D interface. Refer to the following figure and table for instructions. 

 
Figure 15: Current Stimulus Tool 

 

Table 2: Current Stimulus Tool, Instructions 

SETTING DESCRIPTION 

Rated Current  Shows the maximum current available from the DPFlex drive. 

Motor Peak Current Shows the value input as the motor's peak current rating through 
the “Motor Parameters” form. 

Control Mode Allows either “Current” or “Torque” as the control mode. In 
“Current” mode, the DPFlex will drive current through the motor 
phases, but the motor is not commutated. Used in conjunction 
with the digital oscilloscope, this function is useful for fine-tuning 
the current control loop. In “Torque” mode, current is controlled 
and the motor is commutated. 

Control Source Toggle between either “Host” control through the DP.D interface, 
or derive the command signal from the analog input. When using 
the Current Stimulus tool, the analog input signal (0 to 100%) 
maps to a minimum current command of zero to the given “Motor 
Peak Current”. 

Stop/Start Enable or disable the drive output to the motor. 

Direction Use to inverse motor direction. 

DC Sets the current command to a constant value defined by the 
amplitude slider. The current amplitude is given as a percentage 
of the given “Motor Peak Current”. 

Pulse Sets the current command to a square wave defined by the 
amplitude and frequency sliders. The current amplitude is given as 
a percentage of the given “Motor Peak Current”. 
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12.1.2 Velocity Stimulus 

The Velocity Stimulus Tool allows the user to command motor velocity from the 

DP.D interface. Refer to the following figure and table for instructions. 

 
Figure 16: Velocity Stimulus Tool 

 

Table 3: Velocity Stimulus Tool, Instructions 

SETTING DESCRIPTION 

Starting Current The starting current is the current applied to the motor in order to 
move it from its initial stall position. This current must be large 
enough to overcome the static inertia of the motor plus the load.  

Maximum Velocity Enter the maximum permitted velocity.  

Control Source Toggle between either “Host” control through the DP.D interface, 
or derive the command signal from the analog input. When using 
the Velocity Stimulus tool, the analog input signal (0 to 100%) 
maps to a minimum velocity command of 3125 / (Motor Pole 
Pairs) to the given “Maximum Velocity”. 

Stop/Start Enable or disable the drive output to the motor. 

Direction Use to inverse motor direction. 

DC Sets the velocity command to a constant value defined by the 
amplitude slider. The velocity amplitude is given as a percentage 
of the given “Maximum Velocity”. 

Pulse Sets the velocity command to a square wave defined by the 
amplitude and frequency sliders. The velocity amplitude is given 
as a percentage of the given “Maximum Velocity”. 

Rate Control Establish the motor’s rate of acceleration/deceleration by entering 
a value of time corresponding to the interval within which to 
accelerate/decelerate between zero and the input Maximum 
Velocity. A value of 0 in the edit box deactivates Rate Control. 
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12.2 Motor Parameters 

Use the Motor Parameters Form to input the motor’s number of pole pairs (e.g. for a six 

pole motor, the number of pole pairs is three) and its rated peak current. Choose “Apply” 

to update the motor parameters. 

By default, the DP.D software will automatically calculate a set of current loop gains for 

the DPFlex, targeting optimal control about a load point of 20% of the “Motor Peak 

Current”. If during operation the motor is expected to operate above this 20% threshold, 

increase the percentage to reflect the application specific load point. Note that while the 

Motor Verification process provides initial current loop gains, in some cases these 

settings should be fine-tuned using the Current Compensator. 

 
Figure 17: Motor Form 

12.2.1 Motor Verification Tool 

 

CAUTION: GENERAL WARNING 

Failure to ensure that the motor is fixed in place, not connected to a load, and that the shaft can 
turn freely may result in improper configuration and damage to equipment or injury to personnel. 

After the appropriate motor parameters have been applied, choose “Start” to 

begin the Motor Verification process.  

 
Figure 18: Motor Verification Tool 
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During the Motor Verification process, the DP.D software detects the motor’s 

inductance and resistance values and determines the appropriate sensorless 

startup settings. To accomplish this, the DPFlex will output to the motor the 

defined “Motor Peak Current” in order to saturate the motor phases. Note that if 

Motor Verification fails, it is likely that the “Motor Peak Current” is not set to a 

sufficiently high value. To resolve, increase the “Motor Peak Current” setting. 

After the tool has finished, close the Motor Verification Tool and save the 

configuration parameters to the DPFlex’s non-volatile memory by navigating to 

“Registers” -> “Update Registers” in the System Navigation Tree. 

12.3  Current Compensator 

The current loop is a discrete control loop nested inside of the discrete velocity loop that 

ensures the targeted current setpoint is achieved and maintained. 

The Current Compensator Form displays the current gains set for the target motor. It also 

enables the user to re-calculate the gains based on the motor parameters, or to tune the 

gains manually using DP.D's tuning tools.  

 
Figure 19: Current Compensator Form 

Choosing “Tuning Tools” will display the Oscilloscope and the Current Stimulus forms. 

Note that these forms can be arranged as desired and their positions saved by using the 

“View” -> “Save Windows” command. The forms can then be restored to their saved 

positions any time by choosing “View” -> “Restore Windows”. 
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Figure 20: Current Compensator, Tuning Tools 

When tuning the current loop, make sure the motor shaft is connected to the required 

load, that the load is free to move and can move safely, and that the motor itself will not 

move when turning. 

 

CAUTION: GENERAL WARNING 

Failure to ensure that the motor shaft is connected to the required load, that the load is free to 
move and can move safely, and that the motor itself will not move when operating may result in 
improper configuration and damage to equipment or injury to personnel. 

To manually tune the current loop gains, in the Current Stimulus Form choose “Current 

Mode” and “Pulse”. Set the desired values for current pulse frequency and amplitude. 

Then select “Start” to apply current to the motor. In the Oscilloscope Form, choose 

“Auto” to start triggering. After a few seconds, the Oscilloscope will display the current 

stimulus in green and the actual current draw in red. Adjust the current loop gains such 

that rise time, ringing, and overshoot are minimized. 
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Figure 21: Oscilloscope, Current Loop Tuning 

12.4 Velocity Compensator  

The velocity loop is a discrete control loop which issues current commands to the current 

control loop such that the desired velocity setpoint is achieved and maintained. 

The Velocity Compensator Form displays the velocity gains set for the target motor. It 

also allows the user to tune the gains manually using DP.D's tuning tools. 

 
Figure 22: Velocity Compensator Form 
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Choosing “Tuning Tools” will display the Oscilloscope and the Velocity Stimulus forms. 

Note that these forms can be arranged as desired and their positions saved by using the 

“View” -> “Save Windows” command. The forms can then be restored to their saved 

positions any time by choosing “View” -> “Restore Windows”. 

  
Figure 23: Velocity Compensator, Tuning Tools 

When tuning the velocity loop, make sure the motor shaft is connected to the required 

load, that the load is free to move and can move safely, and that the motor itself will not 

move when turning. 

 

CAUTION: GENERAL WARNING 

Failure to ensure that the motor shaft is connected to the required load, that the load is free to 
move and can move safely, and that the motor itself will not move when operating may result in 
improper configuration and damage to equipment or injury to personnel. 

To manually tune the velocity loop gains, in the Velocity Stimulus Form choose “Pulse”. 

Set the desired values for velocity pulse frequency and amplitude. Then select “Start” to 

apply the velocity command to the motor. In the Oscilloscope Form, choose “Auto” to 

start triggering. After a few seconds, the Oscilloscope will display the velocity stimulus 

in green and the actual velocity in red. Adjust the velocity loop gains such that rise time, 

ringing, and overshoot are minimized.  
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Figure 24: Oscilloscope, Velocity Loop Tuning 

12.5 Inputs  

The Inputs Form allows the signals on the input pins to be monitored. Note that while 

monitoring the input pins through DP.D, the drive is disabled.  

 
Figure 25: Inputs Form 
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The “Analog Input” indicator shows the percentage of input voltage across the analog 

input. When “0-5V” is selected, 0 to 5 V scales from 0 to 100%. When “20k pot” is 

selected, 0 to 3.3 V scales from 0 to 100%. 

Two digital inputs are available on the DPFlex. Digital input 1 provides an enable/disable 

signal and digital input 2 signals direction. Note that motor direction cannot be changed 

after the DPFlex has been enabled. “Input One” and “Input Two” indicators turn bright 

red when signal voltage is applied across the corresponding inputs. Use the drop-down 

menu to configure the digital inputs to be either “Active High” or “Active Low”. 

12.6 Faults 

Use the “Status” tab to view the operational status of the DPFlex and motor. Choose 

“Refresh” to update the display with the current status. Choose “Clear Faults” to clear the 

display and update the status. Note that faults are also cleared by power cycling the drive. 

 
Figure 26: Faults, Status Form 

Use the “Configure” tab to adjust fault settings, states, warnings, and error messages. Set 

thresholds by entering values for temperature, current, and voltage in degrees Celsius, 

amperes, and volts, respectively. Choose “Apply” to save settings. 
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Figure 27: Faults, Configure Form 

12.7 Registers 

The Registers Form allows the user to retrieve and save DPFlex settings as (*.dpr) files, 

and to load those settings to DPFlex's non-volatile memory. Also use the Registers Form 

to configure the drive Auto Start mode. Note that changes to the Auto Start settings will 

not take effect until after selecting “Update Registers”, disconnecting the drive from 

DP.D, and then power-cycling the DPFlex. 

 
Figure 28: Registers Form 
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Table 4: Registers Form, Instructions 

SETTING DESCRIPTION 

Auto Start  Drive will enable itself when main power is applied. 

Start on Enable Input Drive will enable itself when main power is applied and digital input 1 is 
active. 

Start-up with fixed torque 
setpoint 

When the drive is enabled, it will commutate the motor with a constant 
torque output defined by “Fixed Torque”.  

Start-up with analog input 
torque setpoint 

 

When the drive is enabled, it will commutate the motor with a torque 
output defined by the analog input. The analog input signal (0 to 100%) 
maps to a minimum torque command of zero to the given “Maximum 
Torque”. 

Start-up with fixed velocity 
setpoint 

 

When the drive is enabled, it will commutate the motor with a constant 
torque output defined by “Fixed Velocity”. Also input a value for “Starting 
Current”. The starting current is the current applied to the motor in order 
to move it from its initial stall position. This current must be large 
enough to overcome the static inertia of the motor plus the load. 

Start-up with analog input 
velocity setpoint 

 

When the drive is enabled, it will commutate the motor with a velocity 
output defined by the analog input. The analog input signal (0 to 100%) 
maps to a minimum velocity command of 3125 / (Motor Pole Pairs) to 
the given “Maximum Velocity”. Also input a value for “Starting Current”. 
The starting current is the current applied to the motor in order to move 
it from its initial stall position. This current must be large enough to 
overcome the static inertia of the motor plus the load. 

Update Registers Store present settings configured in DP.D to the DPFlex’s non-volatile 
memory. 

Save Registers Save present settings stored in the DPFlex’s non-volatile memory to the 
PC as a (*.dpr) file. 

Load Registers Load settings stored on the PC as a (*.dpr) file to the DPFlex’s non-
volatile memory.  

12.8 Digital Output 

The digital output can be configured to be either a speed indicator or a fault indicator.  

When configured to be a speed indicator, the output will change state once every 60 

electrical degrees. When configured to be a fault indicator, the digital output will activate 

when a drive fault occurs. 

 
Figure 29: Digital Output Form 
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12.9 Using the Oscilloscope  

DP.D features a four-channel digital oscilloscope that enables a user to view target 

setpoints and the motor's actual performance. To display the digital oscilloscope, take one 

of the following actions: 

 In the “Tools” menu, choose “Oscilloscope”.  

 In the Current Compensator form or Velocity Compensator forms, choose 

“Tuning Tools”. 

 
Figure 30: Oscilloscope 
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Table 5: Oscilloscope, Instructions 

SETTING DESCRIPTION 

CH1 through CH4 Use to assign a signal to a channel. 

Manual Trigger Select to trigger data logging once immediately. 

Single Select to trigger data logging once. 

Auto Select to trigger data logging continuously and to display captured data. 

Time Base Use the dial to specify the time per division to be displayed on the oscilloscope 
screen (e.g. 100 ms/Div). For any given number of “Points” (e.g. 100) to be captured, 
the “Rate” at which these points are captured will be updated in the “Datalog” field to 
reflect this change (e.g. one data point captured every 10 ms). 

Datalog Specify the “Rate” at which data is captured (e.g. one data point captured every 10 
ms), and the total number of “Points” to be captured (e.g. 100). For any given input, 
the time per division displayed in “Time Base” will be updated to reflect these 
changes (e.g. 100 ms/Div). 

 
Zoom in on the selected segment of the graph.  

 
Zoom out of the selected segment of the graph.  

 
Rescale the display to the input signals' range.  

 
Show or hide the cursor.  

 
Open an oscilloscope configuration.  

 
Save the current oscilloscope configuration.  

 
Print the captured data points.  

 
Copy all captured data points to the clipboard.  

 
Display inputs as graphs.  

 
Display inputs in a table.  

 
Display scaled data.  

 
Position the cursor on the selected input.  

 
Zoom out on the graph to show all captured data points.  

13.0 Control Theory & Implementation 

The DPFlex drive and motor system can be modelled as shown in the diagram below. Except for 

the plant (the motor and its load), all of the blocks in the diagram are parts of the DPFlex. Note 

that the current and velocity control loops within the DPFlex form a nested pair, with the velocity 

loop outputing current commands to the current loop, and the current loop outputting current to 

the motor. For the sake of this analysis, only the inner current loop is shown in the diagram; note 

that the velocity loop surrounding the current loop shares an identical structure. Also the plant is 

taken to be the R-L transfer function of a BLDC motor. 
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Figure 31: System Diagram 

In both the current and velocity control loops, two main goals must be achieved:  

 Keep the output (in this case, current in the motor phases and velocity of the rotor) as 

close as possible to the target setpoint. The result is refered to as the steady state 

response. 

 Maintain an acceptable response to a change in setpoint. This is called the dynamic 

response. 

To achieve these two goals, a second order infinite impulse response filter (biquad compensator) 

is used to approximate a classic PID control loop. 

13.1 Biquad Compensator  

A classic PID control loop can be approximated in the discrete time domain by a 2nd 

order IIR filter with the following z-domain transfer function.  

 Equation 1: Transfer Function, Biquad Compensator, z-Domain 

𝐻(𝑧) =
𝑌(𝑧)

𝑋(𝑧)
=

𝐵0 + 𝐵1𝑧−1 + 𝐵2𝑧−2

1 + 𝐴1𝑧−1 + 𝐴2𝑧−2
 

This transfer function has the following block diagram: 

  
Figure 32: Biquad Filter Diagram 
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13.2 Calculating Filter Coefficients  

DP.D automatically calculates the biquad filter coefficients (𝐵𝑛 and 𝐴𝑛) from the classic 

PID control loop gains (𝐾𝑝, 𝐾𝑖, and 𝐾𝑑). Biquad coefficients are values described in 

Q1.15 format with exponent value. Most good digital signal-processing texts contain a 

description of the Q1.15 numerical format. 

The transfer function of the PID compensator in the s-domain is: 

Equation 2: Transfer Function, PID Compensator, s-Domain 

𝐺(𝑠) =
𝑌(𝑠)

𝑋(𝑠)
= 𝐾𝑝 +

𝐾𝑖

𝑠
+ 𝐾𝑑𝑠 

To find out how PID gains are related to biquad gains, assume that 𝑠 =
𝑧

𝑧−1
 , which is an 

approximation of the bilinear transformation. Then transforming Equation 2 to the z-

domain yields:  

Equation 3: Transfer Function, PID Compensator, z-Domain 

𝐺(𝑧) =
𝑌(𝑧)

𝑋(𝑧)
=

(𝐾𝑝 + 𝐾𝑖 + 𝐾𝑑) + (−𝐾𝑝 − 2𝐾𝑑)𝑧−1 + (𝐾𝑑)𝑧−2

1 − 𝑧−1
 

and by comparing Equation 1 and 3:  

Equation 4: Biquad Compensator Coefficient A1 

𝐴1 = 1 

   

Equation 5: Biquad Compensator Coefficient A2 

𝐴2 = 𝐶 

 

 Equation 6: Biquad Compensator Coefficient B0 

𝐵0 = (𝐾𝑝 + 𝐾𝑖 + 𝐾𝑑) 

  

Equation 7: Biquad Compensator Coefficient B1 

𝐵1 = (−𝐾𝑝 − 2𝐾𝑑) 

 

Equation 8: Biquad Compensator Coefficient B2 

𝐵2 = (𝐾𝑑) 

Equations 4 through 8 show how each of the five biquad filter coefficients are calculated 

from the classic PID control loop gains (𝐾𝑝, 𝐾𝑖, and 𝐾𝑑) whose values are input through 

DP.D for both the current and velocity control loops. 
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14.0 Contacts and Service 

For technical support, sales, or service repair, please visit our website and/or contact: 

NORTH AMERICA 

1 (888) 392-5543 

E-mail: inquiry@alliedmotion.com 

 

EUROPE 

+46 (8) 546 11 100  

E-mail: inquiry@alliedmotion.com 

 

ASIA 

+852 2607 4038 

E-mail: inquiry@alliedmotion.com 

15.0 Revision History 

Table 6: Revision History 

REVISION DESCRIPTION OF CHANGE DATE 

R1 Initial release. February 12, 2015 

R2 Removed “Trigger Settings” instructions not implemented in DP.D v10.88. Added 

hot surface warning, disclaimers, wiring instructions and diagram, references to 

product datasheet, and service contacts. Reorganized sections. 

April 17, 2015 

R3 Removed PCB only mounting instructions.  Added instructions for acceleration 

and deceleration limits in the Velocity Stimulus tool. 

June 2, 2015 
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